Acala Network Node Issues: Unknown Error
Incident Report for Subscan.io
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 02:37 UTC
Investigating
There seems to be some problems with the node/network, the Acala team is actively working on repairs. Please be aware that current data may be inaccurate.
Posted Mar 20, 2024 - 13:22 UTC
This incident affected: Other Networks (Subscan Acala API).