Acala Network Maintenance Notice: Data Inaccuracy
Incident Report for Subscan.io
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 08:40 UTC
Investigating
We identified an issue with the Acala network that may have caused inaccuracies in the data displayed on our platform.
The affected data range spans from March 14, 2024, to March 21, 2024.
Our team is actively working to fix the issue and restore data accuracy.

We will provide updates on this page as soon as we have more information.
Posted Mar 21, 2024 - 05:27 UTC
This incident affected: Other Networks (Subscan Acala API).